Changes between Version 8 and Version 9 of InstallMacosx

Show
Ignore:
Timestamp:
03/09/16 21:35:58 (15 months ago)
Author:
jaysen (IP: 41.150.221.123)
Comment:

Inserted Manual Installation heading before Automatic Installations and moved the latest install note there

Legend:

Unmodified
Added
Removed
Modified
  • InstallMacosx

    v8 v9  
    1 = +Automated installation of wikidpad = 
    2  
    3 == 2016_03 Getting WikidPad Running with wxPython 2.8 on El-Capitan == 
     1= Manual Installation = 
     2 
     3== 2016_03: Getting WikidPad Running with wxPython 2.8 on El-Capitan == 
    44 
    55'''Instructions:''' 
    66 
    7 To start off with I chose to use an older version 2.8 of wxPython, because of numerous reports I'd seen on the WikidPad forums of errors while running under wxPython3 
    8 And as always, I use the latest release of Wikidpad - in this case version 2.3beta13_01. 
     7Using version 2.8 of wxPython and version 2.3beta13_01 of WikidPad. 
    98 
    1091) Download wxPython from https://sourceforge.net/projects/wxpython/files/wxPython/2.8.12.0/ [[BR]] 
     
    1413 
    15143) The wxPython installer package now runs a little further before failing with another weird error to the same effect:  
    16 The Installer could not install the software because there was no software found to install. 
     15''The Installer could not install the software because there was no software found to install.'' 
    1716 
    1817This apparently happens because wxPython is using a legacy script, and the bundled installers were deprecated and are (as of El Capitan release) unsupported.  
     
    7574- open "/usr/local/lib/wxPython-unicode-2.8.12.0/lib/python2.7/site-packages/wx-2.8-mac-unicode/wx/_core.py", line 3917 
    7675- comment out line 3917 
    77   assert callable(handler)  
    78  
    79 9) Wikidpad opens and runs! .. but will only work on wikis using the Gadfly db - No SQLite wikis run. I saw the following error when trying to open my wiki: 
    80 ERROR: required data handler "original_sqlite" unknown to WikidPad 
     76 
     77{{{ 
     78  # assert callable(handler) 
     79}}} 
     80 
     81This seems to be working fine. 
     82  
     83 
     849) Wikidpad opens and runs! .. but will only work on wikis using the Gadfly db - No SQLite wikis run. I saw the following error when trying to open my wiki:[[BR]] 
     85''ERROR: required data handler "original_sqlite" unknown to WikidPad'' 
    8186 
    828710) To fix this, I had to use homebrew to install sqlite3 with universal support: 
     
    103108 
    104109 
    105 ... and WikidPad should launch fine now. 
    106  
    107  
     110... and WikidPad should launch fine now and open sqlite wikis. 
     111 
     112 
     113= +Automated installation of wikidpad = 
    108114 
    109115== 2014_01 ==